Symptômes
Supposons que vous essayez de mettre à niveau une instance miroir de SQL Server 2016 vers SQL Server 2017 en effectuant une mise à niveau propagée. Une fois la mise à niveau terminée, vous pouvez constater que la session de mise en miroir n’est pas en mesure de se synchroniser. Cela peut vous empêcher de terminer la mise à niveau propagée. En outre, un message similaire au suivant est consigné dans le journal des erreurs de SQL Server.
Remarque
- Erreur : 1479, Gravité : 16, État : 1.
- La connexion de mise en miroir à «< adresse> réseau du serveur » a expiré pour la base de données «< nom> de base de données » après 60 secondes sans réponse. Vérifiez les connexions de service et réseau.
Résolution
Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :
Mise à jour cumulative 3 pour SQL Server 2017
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2017
Informations supplémentaires
Pour obtenir plus d’informations sur la mise à niveau des instances en miroir, vous pouvez utiliser le lien suivant :
Mise à niveau des instances en miroir
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.