KB4522404 - CORRECTIF : l’erreur 8965 se produit lorsque vous exécutez DBCC CHECKDB avec PHYSICAL_ONLY option sur la table CCI en SQL Server 2017

S’applique à
SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Standard on Windows

Symptômes

Prenons le scénario suivant :

  • Vous créez un index Columnstore en cluster (CCI) sur une table dans SQL Server 2017.
  • Vous exécutez la commande DBCC CHECKDB avec PHYSICAL_ONLY option sur la table CCI.

Dans ce cas, un message d’erreur semblable au suivant peut s’afficher : En outre, un fichier d’image mémoire est généré.

Msg 8965, Niveau 16, État 1, Ligne LineNumber

Erreur de table : ID d’objet ObjectID, ID d’index IndexID, ID de partition PartitionID, ID d’unité d’allocation UnitID (tapez les données dans la ligne). Nœud de données hors ligne à la page (1:65336), emplacement 1, ID de texte TextID est référencé par la page (0:0), emplacement 0, mais n’est pas visible dans l’analyse.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.