KB4053392 - CORRECTIF : une erreur de résolution de noms se produit lorsque IPv6 est désactivé au démarrage en SQL Server 2017 sur Linux

S’applique à
SQL Server 2017 Developer Linux SQL Server 2017 Enterprise on Linux SQL Server 2017 Enterprise Core on Linux SQL Server 2017 Standard on Linux

Symptômes

Considérez que le protocole IPv6 est désactivé au démarrage de SQL Server 2017 sur Linux. Par conséquent, toutes les connexions sortantes initiées par SQL Server pour se connecter à un serveur lié ou aux serveurs secondaires d’un groupe de disponibilité par nom d’hôte échouent avec une erreur en raison de problèmes de résolution de nom.

Solution de contournement

Utiliser l’adresse IP (Internet Protocol) au lieu du nom d’hôte pour se connecter à SQL Server ou supprimer le paramètre ipv6.disable=1 dans le fichier de ligne de commande de démarrage pour activer IPv6.

Résolution

Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :

Mise à jour cumulative 2 pour SQL Server 2017

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2017

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.