Symptômes
Dans le cadre de la récupération de base de données en mémoire de SQL Server, une tâche parallèle est lancée pour récupérer des objets en mémoire. Dans certains scénarios, cette tâche peut échouer. Il existe une condition de concurrence pendant la récupération du journal : si l’échec se produit lors de la dernière phase de restauration du journal, la tâche parallèle manque la notification d’échec et ne se ferme pas. Cela se traduit par un blocage de la base de données lors de la récupération.
Remarque Il s’agit d’un problème de condition de concurrence temporaire, et un redémarrage du serveur débloquerait la base de données.
Résolution
Ce correctif est inclus dans la mise à jour suivante pour SQL Server :
Mise à jour cumulative 8 pour SQL Server 2017
Cette mise à jour corrige la notification manquée afin que la tâche de récupération détecte l’échec et laisse la base de données comme échec de la récupération. Une instruction ALTER DATABASE SET ONLINE peut ensuite être émise pour redémarrer le processus de récupération de base de données.
À propos des builds de SQL Server
Chaque nouvelle build de SQL Server contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la version précédente. Nous vous recommandons d’installer la version la plus récente pour votre version de SQL Server :
La dernière build pour SQL Server 2017
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
Découvrez la terminologie standard utilisée par Microsoft pour décrire les mises à jour logicielles.