Symptômes
Prenons le scénario suivant :
- Vous avez une instance de Microsoft SQL Server 2017 dont la configuration du serveur est liée à une autre instance de SQL Server.
- Un utilisateur sans droit de contournement de la stratégie locale de vérification de parcours exécute la première requête de serveur lié après un redémarrage du service SQL Server.
Dans ce scénario, la requête initiale du serveur lié est exécutée et chaque requête de serveur lié successive, effectuée par un utilisateur, renvoie des messages d’erreur semblables à ce qui suit :
Remarque
Le fournisseur OLE DB « SQLNCLI11 » pour le serveur lié « server_name » a renvoyé le message « Une erreur liée au réseau ou spécifique à instance s’est produite lors de l’établissement d’une connexion à SQL Server. Le serveur est introuvable ou n’est pas accessible. Vérifiez que le nom d’instance est correct et que SQL Server est configuré de manière à autoriser les connexions à distance. Pour plus d’informations, reportez-vous à la documentation en ligne de SQL Server. »
Le fournisseur OLE DB « SQLNCLI11 » pour le serveur lié « server_name » a renvoyé le message « Le client ne parvient pas à établir la connexion ».
Msg 21, Niveau 16, État 1, Ligne 0
Chiffrement non pris en charge sur le client
Résolution
Ce problème est résolu dans la mise à jour suivante pour SQL Server :
Mise à jour cumulative 12 pour SQL Server 2017
À propos des builds de SQL Server
Chaque nouvelle build de SQL Server contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la version précédente. Nous vous recommandons d’installer la version la plus récente pour votre version de SQL Server :
La dernière build pour SQL Server 2017
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
Découvrez la terminologie standard utilisée par Microsoft pour décrire les mises à jour logicielles.