Symptômes
Supposons que vous utilisez SQL Server 2017. Vous pouvez recevoir l’assertion suivante à des moments aléatoires qui est ajoutée pour protéger la transaction contre une condition de concurrence entre une procédure en cours d’exécution et une modification simultanée de la même procédure. Lorsque l’assertion se produit, vous remarquerez peut-être les effets secondaires du délai d’expiration du bail. En outre, le groupe de disponibilité (AG) Always On et la base de données principale passent à l’état de résolution. Après le correctif, vous recevez l’erreur 41305 (La transaction actuelle n’a pas pu être validée en raison d’un échec de validation en lecture répétable) au lieu de l’assertion. Comme l’erreur le suggère, dans ce cas, vous devez réexécuter la requête ayant échoué.
DÉBUT DU VIDAGE DE LA PILE :
SpidIdSpidId CurrentTime
Location : « LocationPath » :LocationId
Expression : HK_E_ALTERED_TABLE_IS_MODIFIED != hr
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.