Symptômes
Lorsque vous exécutez une requête qui utilise la fonctionnalité de jointure adaptative dans SQL Server 2017, vous remarquerez que la requête ne s’exécute pas. En outre, un message d’erreur semblable au suivant peut s’afficher :
Remarque
« Erreur de plan incorrect »
Msg 596, Niveau 21, État 1, Ligne LineNumber
Impossible de continuer l’exécution car la session est à l’état d’arrêt.
Msg 0, Niveau 20, État 0, Ligne LineNumber
Une grave erreur s’est produite sur la commande actuelle. Les résultats, s’il y en a, doivent être ignorés.
Résolution
Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :
Mise à jour cumulative 11 pour SQL Server 2017
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2017
Solution de contournement
Comme solution de contournement pour ce problème, vous pouvez désactiver la fonctionnalité Jointure adaptative pour la requête.
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.